kernel: usb: move phy-qcom-ipq806x-usb to ipq806x modules.mk
authorAnsuel Smith <ansuelsmth@gmail.com>
Sun, 9 Aug 2020 14:31:05 +0000 (16:31 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 13 Aug 2020 00:12:12 +0000 (02:12 +0200)
This driver is only used by ipq806x SoCs. Move it there and drop
dependency from ipq40xx since it's not used anywere.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
[rebase on changes to previous patches]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Tested-by: Paul Blazejowski <paulb@blazebox.homeip.net> [R7800]
package/kernel/linux/modules/usb.mk
target/linux/ipq806x/modules.mk [new file with mode: 0644]

index 5db02449680c441d49411eac6162a55f9304f3d8..fc411c5a542da0019732d201e5dae841cb8281ea 100644 (file)
@@ -70,24 +70,6 @@ endef
 $(eval $(call KernelPackage,usb-phy-nop))
 
 
 $(eval $(call KernelPackage,usb-phy-nop))
 
 
-define KernelPackage/phy-qcom-ipq806x-usb
-  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
-  DEPENDS:=@(TARGET_ipq40xx||TARGET_ipq806x)
-  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
-  FILES:= \
-    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/phy-qcom-ipq806x-usb/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
-
-
 define KernelPackage/phy-ath79-usb
   TITLE:=Support for ATH79 USB PHY
   KCONFIG:=CONFIG_PHY_AR7100_USB \
 define KernelPackage/phy-ath79-usb
   TITLE:=Support for ATH79 USB PHY
   KCONFIG:=CONFIG_PHY_AR7100_USB \
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
new file mode 100644 (file)
index 0000000..605504b
--- /dev/null
@@ -0,0 +1,16 @@
+define KernelPackage/phy-qcom-ipq806x-usb
+  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
+  DEPENDS:=@TARGET_ipq806x
+  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
+  FILES:= \
+    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/phy-qcom-ipq806x-usb/description
+ This driver provides support for the integrated DesignWare
+ USB3 IP Core within the QCOM SoCs.
+endef
+
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))