kernel build cleanup
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 17:24:20 +0000 (17:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Mar 2007 17:24:20 +0000 (17:24 +0000)
SVN-Revision: 6464

include/image.mk
include/kernel-build.mk
target/linux/atheros-2.6/image/Makefile
target/linux/rb532-2.6/image/Makefile

index 9c170af11bc64f34b8f2427e3c18cd90d50d8370..78e1a2fdc80562cc20f0efbb72d4376b21301b09 100644 (file)
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+  endef
 endif
 
 
index 6aec7c7270b8b060e3b52306ae0a915ffd2f6903..3a17182a27a2b8d9b04def3985ddbf56b7fecc73 100644 (file)
@@ -136,6 +136,7 @@ define Kernel/CompileImage/Default
        $(call Kernel/SetInitramfs)
        $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
+       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 define Kernel/CompileImage
        $(call Kernel/CompileImage/Default)
index dfd1746fd3db01404dd771de604831a446cf2a5b..1d32a4bd46e2482be08a620d26b9106a7927babc 100644 (file)
@@ -7,10 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/Prepare
-       cp $(KDIR)/linux-*/vmlinux $(KDIR)/vmlinux.elf
-endef
-
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
index b35b0b1e7bb686278900de0f5239001fd03ee19d..e6794c036d4d341b4d18c3e71e047493b5426acc 100644 (file)
@@ -31,7 +31,6 @@ endef
 define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
-       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 
 define Image/BuildKernel