brcm63xx: Add DT support for A4001N1
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:40 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:40 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42244

29 files changed:
target/linux/brcm63xx/dts/a4001n1.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.14/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.14/552-board_96348gw-10_reset_button.patch
target/linux/brcm63xx/patches-3.14/553-boards_probe_switch.patch
target/linux/brcm63xx/patches-3.14/554-board_DWVS0_leds_buttons.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/adb.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/a4001n1.dts b/target/linux/brcm63xx/dts/a4001n1.dts
new file mode 100644 (file)
index 0000000..2bdd201
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "ADB P.DG A4001N1";
+       compatible = "adb,a4001n1", "brcm,bcm6328";
+};
index 137cc73250b5e1216eee074c8cda7681275f8293..31dd3994cce96242c96ba93d0a359a8ad0c8d075 100755 (executable)
@@ -245,8 +245,6 @@ define Image/Build
 
        # ADB P.DG A4001N
        $(call Image/Build/CFE,$(1),96328dg2x2,6328,A4001N,,--pad 4)
-       # ADB P.DG A4001N1
-       $(call Image/Build/CFE,$(1),963281T_TEF,6328,A4001N1,,--pad 8)
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
        # BT Voyager V210_ROI, V210_WB
@@ -345,6 +343,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-4M-fla
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-flash-generic,,--pad 4))
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-flash-generic,,--pad 8))
 
+# ADB P.DG A4001N1
+$(eval $(call CfeImageDTB,A4001N1,a4001n1,963281T_TEF,6328,A4001N1,,--pad 8))
 # Asmax AR 1004g
 $(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
 # Comtrend AR-5381u
index 45ceec345dff455f1fb69c330cabc96dede4e7a2..272ee64e27163cc9fedba28c09f16d79831b2752 100644 (file)
@@ -1,11 +1,12 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -236,6 +236,133 @@ static struct board_info __initdata boar
+@@ -236,6 +236,134 @@ static struct board_info __initdata boar
        },
  };
  
 +static struct board_info __initdata board_A4001N1 = {
 +      .name                                   = "963281T_TEF",
++      .of_board_id                    = "adb,a4001n1",
 +      .expected_cpu_id                        = 0x6328,
 +
 +      .has_uart0                              = 1,
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2695,6 +2822,7 @@ static const struct board_info __initcon
+@@ -2695,6 +2823,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 128354e476c82041baf4d922b10f0e146acda6a5..1ed660d866721c75b8182db7181fb9c3c23bda9c 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2821,6 +2931,7 @@ static const struct board_info __initcon
+@@ -2822,6 +2932,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index f690bc5f91ce16552018d4f73686a54db92a4965..93c83afe6ac00bc11f01b8cd1cfdbada9784ed18 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2931,6 +3017,7 @@ static const struct board_info __initcon
+@@ -2932,6 +3018,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 1d1a45ca20213f1a1f4ca96b8fd211e6cb437019..4e46193be4fd0899fd60a6da94fb7251e0997cc4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -840,6 +840,55 @@ static struct board_info __initdata boar
+@@ -841,6 +841,55 @@ static struct board_info __initdata boar
  
        .has_uart0                      = 1,
  };
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3031,6 +3080,7 @@ static const struct board_info __initcon
+@@ -3032,6 +3081,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index f10f5d13a53a50feb30ac9193bef6168af4a9c09..1024dcead0edc67aacec7d7c098200eb3e17e9cc 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2678,6 +2679,405 @@ static struct board_info __initdata boar
+@@ -2679,6 +2680,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3116,6 +3516,9 @@ static const struct board_info __initcon
+@@ -3117,6 +3517,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index efa039f9c644063e1911277bbd3b564a30a5f5dd..5fcb3bae3dc583023fb3849b89035cf29e544e56 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -890,6 +890,60 @@ static struct board_info __initdata boar
+@@ -891,6 +891,60 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3481,6 +3535,7 @@ static const struct board_info __initcon
+@@ -3482,6 +3536,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index 00572a487747ff3a628e9bb5d0d7b6c6a993da82..fc8fe6280b88146be93d97123816a50c3049e3f3 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -664,6 +664,122 @@ static struct board_info __initdata boar
+@@ -665,6 +665,122 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3525,6 +3641,7 @@ static const struct board_info __initcon
+@@ -3526,6 +3642,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index 0298f7cdf4ff8360f138101e000fee320072c23b..d4ad4e067e5112ba68d7667d9d9561217dd718bf 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3480,6 +3480,96 @@ static struct board_info __initdata boar
+@@ -3481,6 +3481,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3697,6 +3787,7 @@ static const struct board_info __initcon
+@@ -3698,6 +3788,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 2b6a7e7e80ee57dc7ebeee5f38ee7f939b7a4a97..10ac31648b0dd40ae9845e92e9d2b9df3c5bf876 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2305,6 +2305,99 @@ static struct board_info __initdata boar
+@@ -2306,6 +2306,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 2465d1405457bb5613e6fd896a22c9718d320f3c..7b1443bf1b1e335b307dd08c397e8cd36458826f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1776,6 +1776,19 @@ static struct board_info __initdata boar
+@@ -1777,6 +1777,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index 6ed480208987425850adf5785bbac1481b040b7f..5a249c5f822113e278a615f63c06846b13606a35 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1172,6 +1172,17 @@ static struct board_info __initdata boar
+@@ -1173,6 +1173,17 @@ static struct board_info __initdata boar
                        .active_low     = 1,
                },
        },
index 2744170ffd0d4cf9f90468c9da31f7d83d08a845..4fa865d05aa7cf5e805186fea8a04897b031bfa6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -794,6 +794,8 @@ static struct board_info __initdata boar
+@@ -795,6 +795,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -9,7 +9,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -838,6 +840,8 @@ static struct board_info __initdata boar
+@@ -839,6 +841,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -18,7 +18,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1128,6 +1132,8 @@ static struct board_info __initdata boar
+@@ -1129,6 +1133,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -27,7 +27,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1202,6 +1208,8 @@ static struct board_info __initdata boar
+@@ -1203,6 +1209,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1483,6 +1491,8 @@ static struct board_info __initdata boar
+@@ -1484,6 +1492,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1662,6 +1672,8 @@ static struct board_info __initdata boar
+@@ -1663,6 +1673,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1738,6 +1750,8 @@ static struct board_info __initdata boar
+@@ -1739,6 +1751,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1761,6 +1775,8 @@ static struct board_info __initdata boar
+@@ -1762,6 +1776,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1782,6 +1798,8 @@ static struct board_info __initdata boar
+@@ -1783,6 +1799,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2127,6 +2145,8 @@ static struct board_info __initdata boar
+@@ -2128,6 +2146,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2181,6 +2201,8 @@ static struct board_info __initdata boar
+@@ -2182,6 +2202,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2323,6 +2345,8 @@ static struct board_info __initdata boar
+@@ -2324,6 +2346,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2442,6 +2466,8 @@ static struct board_info __initdata boar
+@@ -2443,6 +2467,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
index b254a0b8ab370a6c2510575c157b7380781116f4..4ebe502967ec5594a65a5a5945cba32f7f1898a2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2474,6 +2474,94 @@ static struct board_info __initdata boar
+@@ -2475,6 +2475,94 @@ static struct board_info __initdata boar
  
        .has_ohci0                      = 1,
        .has_ehci0                      = 1,
index b465ef3ee943996294ea70a4e05708ea225d6d75..ef33a416997d1be8298651992a6c04e0ef20c1fe 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3955,6 +4042,9 @@ static const struct board_info __initcon
+@@ -3956,6 +4043,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 81d6dd34e590a0efe77b9644436ab7c62b75ad39..9723d2ae727abdc4bb3ac88c47b66afa41fd3988 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4044,6 +4132,7 @@ static const struct board_info __initcon
+@@ -4045,6 +4133,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 95ebdbd839daf7ccc8ac4cbb5ca20779949d1a8a..1e26edf9dc2b21fd6e65c0338cbf04fed4f639b0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4124,6 +4124,75 @@ static struct board_info __initdata boar
+@@ -4125,6 +4125,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4204,6 +4273,9 @@ static const struct board_info __initcon
+@@ -4205,6 +4274,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 57858e3b26fb6cd2b41a706c509dcc7487ef96ad..2d520473d3d39d235ad388088ef8fe9eaa7e2cc6 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1434,6 +1434,52 @@ static struct board_info __initdata boar
+@@ -1435,6 +1435,52 @@ static struct board_info __initdata boar
        },
  };
  
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4244,6 +4290,7 @@ static const struct board_info __initcon
+@@ -4245,6 +4291,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 2d698f4e711b4fd8a684805c1c428665269b1c3a..8f46d1b55b2e389520864b16c214f4f7a43ca60f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4236,6 +4236,108 @@ static struct board_info __initdata boar
+@@ -4237,6 +4237,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4322,6 +4424,7 @@ static const struct board_info __initcon
+@@ -4323,6 +4425,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index 6cd4c326d772a877175eb1d186da6d6f39e56480..b0208171ae441ba297ab4826dc76f2497f6bf375 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4173,6 +4173,131 @@ static struct board_info __initdata boar
+@@ -4174,6 +4174,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4423,6 +4548,7 @@ static const struct board_info __initcon
+@@ -4424,6 +4549,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 4a251db0a83794cc6704a3a7026320723bce597f..428e796d04b9fd7c489c45d3d50d24dd4bf4f8b6 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4167,6 +4168,118 @@ static struct board_info __initdata boar
+@@ -4168,6 +4169,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4546,6 +4659,7 @@ static const struct board_info __initcon
+@@ -4547,6 +4660,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 7aa4e5ed269877e56df756e5f5303ac0e22d4112..29e3a797ea545bb7155f493917037e778bbc6689 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4169,6 +4169,117 @@ static struct board_info __initdata boar
+@@ -4170,6 +4170,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4659,6 +4770,7 @@ static const struct board_info __initcon
+@@ -4660,6 +4771,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 49c86773193a7c86121cb56b06913e29c6d8af78..9a6ac99667981dc12bcd7bc04037d1afef5077e0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4280,6 +4280,117 @@ static struct board_info __initdata boar
+@@ -4281,6 +4281,117 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4771,6 +4882,7 @@ static const struct board_info __initcon
+@@ -4772,6 +4883,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index e00bf34973385f4f957039a6e4a28819edf5a2ea..1ed7580502c5b8206fa31fd6796e83078d73355c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4178,6 +4178,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4179,6 +4179,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4881,6 +4971,7 @@ static const struct board_info __initcon
+@@ -4882,6 +4972,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 8e76a16828abd61bdd87d96daf0a4e911eb25e06..eb90bcc1c887818358f7c3311d7476e873f168ec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3225,6 +3225,56 @@ static struct board_info __initdata boar
+@@ -3226,6 +3226,56 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4955,6 +5005,7 @@ static const struct board_info __initcon
+@@ -4956,6 +5006,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index c1f505baba95b192af432624bfe77ad291e30375..ee5cf9ab2f9483680298a33721c72afffd726a53 100644 (file)
@@ -95,8 +95,8 @@
 +
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
-       .expected_cpu_id                        = 0x6328,
-@@ -4956,6 +5045,7 @@ static const struct board_info __initcon
+       .of_board_id                    = "comtrend,wap-5813n",
+@@ -4957,6 +5046,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index e2dbcac1e863a3491e1481867730671030fe7abb..80fe15cf5b9a3cb55c5af54d946636946bae1b22 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5039,6 +5174,7 @@ static const struct board_info __initcon
+@@ -5040,6 +5175,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
diff --git a/target/linux/brcm63xx/profiles/adb.mk b/target/linux/brcm63xx/profiles/adb.mk
new file mode 100644 (file)
index 0000000..864224c
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/A4001N1
+  NAME:=ADB P.DG A4001N1
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/A4001N1/Description
+  Package set optimized for A4001N1.
+endef
+$(eval $(call Profile,A4001N1))