ramips: add kmod-mt7615e to Xiaomi Mi Router 3 Pro images
authorOzgur Can Leonard <ozgurcan@gmail.com>
Fri, 2 Aug 2019 18:55:41 +0000 (21:55 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 18 Jan 2020 15:08:16 +0000 (16:08 +0100)
Now that the mt76/mt7615e driver is in Openwrt, might as well use it.

Signed-off-by: Ozgur Can Leonard <ozgurcan@gmail.com>
(cherry picked from commit d7c082ba4f7de97b3708d1f4a064954ffc774778)

target/linux/ramips/dts/MIR3P.dts
target/linux/ramips/image/mt7621.mk

index cd929e5e3361990837ce375f65adffe924b20f2c..ff250136f27aebcaf6fb43d36993bc742c45f642 100644 (file)
 
 &pcie0 {
        wifi@0,0 {
-               compatible = "pci14c3,7615";
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
        };
 };
 
 &pcie1 {
        wifi@0,0 {
-               compatible = "pci14c3,7615";
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                mediatek,mtd-eeprom = <&factory 0x8000>;
                ieee80211-freq-limit = <5000000 6000000>;
index 5001a5da82737c4110d4e15db06585020c597083..53a264f527a673dd9f1df5bc3cd6e0b60cf194db 100644 (file)
@@ -266,7 +266,8 @@ define Device/xiaomi_mir3p
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
   DEVICE_PACKAGES := \
-       kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic uboot-envtools
+       kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
+       uboot-envtools
 endef
 TARGET_DEVICES += xiaomi_mir3p