kernel: kmod-rxrpc: handle renamed kernel module
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Nov 2017 21:15:14 +0000 (22:15 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 16 Dec 2017 21:14:12 +0000 (22:14 +0100)
The kernel module was renamed with kernel 4.11, handle that in the
package definition.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/netsupport.mk

index 178a00a3ee46d99c07efa5c2191815eaf40244fe..836034ad122574b287307985cc2ff5f941052903 100644 (file)
@@ -925,9 +925,10 @@ define KernelPackage/rxrpc
        CONFIG_RXKAD=m \
        CONFIG_AF_RXRPC_DEBUG=n
   FILES:= \
-       $(LINUX_DIR)/net/rxrpc/af-rxrpc.ko \
+       $(LINUX_DIR)/net/rxrpc/af-rxrpc.ko@lt4.11 \
+       $(LINUX_DIR)/net/rxrpc/rxrpc.ko@ge4.11 \
        $(LINUX_DIR)/net/rxrpc/rxkad.ko@lt4.7
-  AUTOLOAD:=$(call AutoLoad,30,rxkad@lt4.7 af-rxrpc)
+  AUTOLOAD:=$(call AutoLoad,30,rxkad@lt4.7 af-rxrpc.ko@lt4.11 rxrpc.ko@ge4.11)
   DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
 endef