ipq40xx: Select correct board-2.bin for EnGenius EMD1
authorSven Eckelmann <sven@narfation.org>
Sat, 11 Sep 2021 06:33:30 +0000 (08:33 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 12 Sep 2021 16:52:30 +0000 (18:52 +0200)
The board data file for the EnGenius EMD1 is not part of the default
board-2.bin which is shipped by ath10k-board-qca4019. As result, the wrong
calibration information will be loaded into the wifi chip.

Fixes: 51f303597839 ("ipq40xx: add support for EnGenius EMD1")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
target/linux/ipq40xx/image/generic.mk

index c7e3583613ef085731eb9aa110f4fff662850db8..b1a3bac29165a7dfd0e9d80c0bdd32ceec9b39b2 100644 (file)
@@ -419,6 +419,7 @@ define Device/engenius_emd1
        IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       DEVICE_PACKAGES := ipq-wifi-engenius_emd1
 endef
 TARGET_DEVICES += engenius_emd1