iptables: make kmod-ipt-debug part of default ALL build
authorYousong Zhou <yszhou4tech@gmail.com>
Fri, 26 Jan 2018 06:40:25 +0000 (14:40 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 26 Jan 2018 07:29:02 +0000 (15:29 +0800)
The iptables TRACE target is only available in raw table that's why the
dependency was moved from iptables-mod-trace into kmod-ipt-debug

Fixes FS#1219

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/kernel/linux/modules/netfilter.mk
package/network/utils/iptables/Makefile

index f45845750075f01f3a51a01a2fa657ce664560cf..097c0cab03d529c464c627cc5a0dbdd39d5b280b 100644 (file)
@@ -447,10 +447,9 @@ $(eval $(call KernelPackage,ipt-nfqueue))
 define KernelPackage/ipt-debug
   TITLE:=Module for debugging/development
   KCONFIG:=$(KCONFIG_IPT_DEBUG)
-  DEFAULT:=n
   FILES:=$(foreach mod,$(IPT_DEBUG-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_DEBUG-m)))
-  $(call AddDepends/ipt)
+  $(call AddDepends/ipt,+kmod-ipt-raw +IPV6:kmod-ipt-raw6)
 endef
 
 define KernelPackage/ipt-debug/description
index e09c35c696a147b8e11d5ff26fb660ed0762fabb..207676e2900ab9ec09dd806cceb0bb42d5a96187 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.netfilter.org/iptables
@@ -218,7 +218,7 @@ define Package/iptables-mod-nflog/description
 endef
 
 define Package/iptables-mod-trace
-$(call Package/iptables/Module, +kmod-ipt-debug +kmod-ipt-raw)
+$(call Package/iptables/Module, +kmod-ipt-debug)
   TITLE:=Netfilter TRACE target
 endef