ipq40xx: convert EZVIZ CS-W3-WD1200G-EUP to DSA
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 18 May 2023 20:51:08 +0000 (22:51 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 20 May 2023 13:19:14 +0000 (15:19 +0200)
Convert the repeater to DSA.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cs-w3-wd1200g-eup.dts
target/linux/ipq40xx/image/generic.mk

index cb318d36a30e392cb7128060cf15506718a4ec14..28648c0db99e53321ca9b25f3cce2f10e458bbf3 100644 (file)
@@ -82,6 +82,7 @@ ipq40xx_setup_interfaces()
                ucidef_set_interface_lan "sw-eth1 sw-eth2"
                ;;
        aruba,ap-303h|\
+       ezviz,cs-w3-wd1200g-eup|\
        netgear,rbr50|\
        netgear,rbs50|\
        netgear,srr60|\
index dea5c2dc36d51e77d88a556c696fc96c873721db..22a48c12c44ef4036216f7417559d4403ae31552 100644 (file)
        status = "okay";
 };
 
+&gmac {
+       status = "okay";
+       nvmem-cells = <&macaddr_art_0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport2 {
+       status = "okay";
+       label = "lan3";
+};
+
+&swport3 {
+       status = "okay";
+       label = "lan2";
+};
+
+&swport4 {
+       status = "okay";
+       label = "lan1";
+};
+
+&swport5 {
+       status = "okay";
+       label = "wan";
+       nvmem-cells = <&macaddr_art_6>;
+       nvmem-cell-names = "mac-address";
+};
+
+&ethphy0 {
+       status = "disabled";
+};
+
 &wifi0 {
        status = "okay";
        qcom,ath10k-calibration-variant = "ezviz-cs-w3-wd1200g-eup";
index c8b8ec936b4beea2374c2bb2a0d14a9631501b9f..59bdd04296294e025771ede0bcdeeabee3a7fff4 100644 (file)
@@ -555,8 +555,7 @@ define Device/ezviz_cs-w3-wd1200g-eup
        DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
                Upgrade via sysupgrade mechanism is not possible.
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
+TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
 
 define Device/glinet_gl-a1300
        $(call Device/FitImage)