ath9k: compile out the ath9k rate control
authorFelix Fietkau <nbd@openwrt.org>
Thu, 30 Sep 2010 15:00:06 +0000 (15:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 30 Sep 2010 15:00:06 +0000 (15:00 +0000)
SVN-Revision: 23163

package/mac80211/Makefile
package/mac80211/patches/017-remove_ath9k_rc.patch [new file with mode: 0644]

index 259f744ee5f25d064c83bf877c5e36d32f0184be..f65a823bd86642fb54675a4ecdacb75a87de9b27 100644 (file)
@@ -24,7 +24,6 @@ PKG_BUILD_PARALLEL:=1
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_kmod-mac80211 \
        CONFIG_PACKAGE_MAC80211_DEBUGFS \
-       CONFIG_PACKAGE_ATH9K_USE_MINSTREL \
        CONFIG_PACKAGE_ATH_DEBUG \
        CONFIG_ATH_USER_REGD \
 
@@ -446,17 +445,6 @@ This module adds support for wireless adapters based on
 Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.
 endef
 
-define KernelPackage/ath9k/config
-       menu "Configuration"
-               depends PACKAGE_kmod-ath9k
-
-       config PACKAGE_ATH9K_USE_MINSTREL
-               bool "use the new minstrel_ht rate control for ath9k"
-               default y
-
-       endmenu
-endef
-
 define KernelPackage/carl9170
   $(call KernelPackage/mac80211/Default)
   TITLE:=Driver for Atheros AR9170 USB sticks
@@ -837,7 +825,6 @@ BUILDFLAGS:= \
        -D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
        -DCONFIG_MAC80211_RC_MINSTREL_HT \
        $(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1) \
-       $(if $(CONFIG_PACKAGE_ATH9K_USE_MINSTREL),-DATH9K_USE_MINSTREL) \
        $(if $(CONFIG_PACKAGE_RT2X00_LIB_DEBUGFS),-DCONFIG_RT2X00_LIB_DEBUGFS) \
        $(if $(CONFIG_PACKAGE_RT2X00_DEBUG),-DCONFIG_RT2X00_DEBUG) \
        $(if $(NEED_RT2X00_LIB_HT),-DCONFIG_RT2X00_LIB_HT) \
diff --git a/package/mac80211/patches/017-remove_ath9k_rc.patch b/package/mac80211/patches/017-remove_ath9k_rc.patch
new file mode 100644 (file)
index 0000000..f9e8756
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/config.mk
++++ b/config.mk
+@@ -204,7 +204,7 @@ CONFIG_ATH9K_COMMON=m
+ # as default once we get minstrel properly tested and blessed by
+ # our systems engineering team. CCK rates also need to be used
+ # for long range considerations.
+-CONFIG_ATH9K_RATE_CONTROL=y
++# CONFIG_ATH9K_RATE_CONTROL=y
+ CONFIG_COMPAT_IWLWIFI=m