kernel/modules: kmod-crypto-xts: depend on kmod-crypto-gf128
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:02:01 +0000 (13:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:02:01 +0000 (13:02 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43836

package/kernel/linux/modules/crypto.mk

index 5d4916095925bd705c6eddce2bdf430ecf417754..eec7934f164232f8cda9a40d73f1e27633679f7a 100644 (file)
@@ -594,17 +594,10 @@ $(eval $(call KernelPackage,crypto-test))
 
 define KernelPackage/crypto-xts
   TITLE:=XTS cipher CryptoAPI module
-  DEPENDS:=+kmod-crypto-manager
-  KCONFIG:= \
-       CONFIG_CRYPTO_GF128MUL \
-       CONFIG_CRYPTO_XTS
-  FILES:= \
-       $(LINUX_DIR)/crypto/xts.ko \
-       $(LINUX_DIR)/crypto/gf128mul.ko
-  AUTOLOAD:=$(call AutoLoad,09, \
-       gf128mul \
-       xts \
-  )
+  DEPENDS:=+kmod-crypto-gf128 +kmod-crypto-manager
+  KCONFIG:=CONFIG_CRYPTO_XTS
+  FILES:=$(LINUX_DIR)/crypto/xts.ko
+  AUTOLOAD:=$(call AutoLoad,09,xts)
   $(call AddDepends/crypto)
 endef