Fix install of iptables pkg-config files.
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 08:10:55 +0000 (08:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 08:10:55 +0000 (08:10 +0000)
libiptc.pc depends on libip[4|6]tc.pc, thus all of those need to be
installed.
Should fix collectd build and thus #13146; which should make collectd
appear in snapshots again.

Signed-off-by: Danny Baumann <dannybaumann@web.de>
SVN-Revision: 36509

package/network/utils/iptables/Makefile

index 371153f665c2cbad4497dd1a9b9a9be685472c72..4140acb77d4e9ba6ab5b74222891c8fa37daca9f 100644 (file)
@@ -376,7 +376,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libiptc.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libip*tc.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/iptables/install