CMakeLists.txt: add -Wimplicit-fallthrough to the compiler flags
authorAlexander Couzens <lynxis@fe80.eu>
Thu, 5 Jul 2018 01:13:03 +0000 (03:13 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Wed, 11 Jul 2018 20:12:15 +0000 (22:12 +0200)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Acked-by: Hans Dedecker <dedeckeh@gmail.com>
CMakeLists.txt

index 696412b51f451d110cdbca87c164f066cddf7da3..50f62bd3ceae698c36e2bcc5e34b9b4aad927222 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-unknown-warning-option -Wno-format-truncation -Wimplicit-fallthrough)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")